livestream/docker.nix
2023-07-26 03:23:33 +03:00

20 lines
322 B
Nix

{
pkgs,
default,
nix2container,
}:
nix2container.packages.${pkgs.system}.nix2container.buildImage {
name = "livestream";
tag = "latest";
copyToRoot = with pkgs; [
cacert
ffmpeg
];
config = {
entrypoint = ["${default}/bin/livestream"];
workdir = "/app";
exposed_ports = [3000];
};
}