clip-maker/build.nix
2023-07-10 01:41:07 +03:00

19 lines
No EOL
353 B
Nix

{ pkgs, buildGoModule, lib }: buildGoModule rec {
src = ./.;
name = "clip-maker";
vendorSha256 = null;
ldflags = [
"-s"
"-w"
];
nativeBuildInputs = with pkgs; [
makeWrapper
];
postInstall = ''
wrapProgram $out/bin/clip-maker --prefix PATH : ${lib.makeBinPath [ pkgs.ffmpeg ]}
'';
}